Bookshelf 2

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

C++版本一

DP 

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
int n,m;
int c[1100],dp[1001000 ];
int main()
{
        scanf("%d%d",&n,&m);
        int sum=0;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++){
            scanf("%d",&c[i]);
            sum+=c[i];
        }

        sort(c,c+n);

        for(int i=0;i<n;i++){
            for(int k=sum;k>=c[i];k--){
                dp[k]=max(dp[k],dp[k-c[i]]+c[i]);
            }
        }
        for(int i=m;i<=sum;i++){
            if(dp[i]>=m){
               cout<< dp[i]-m <<endl;
               break;
            }
        }


    //cout << "Hello world!" << endl;
    return 0;
}

 C++版本二

DP

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[2000002], h[22];
int main()
{
    int n, m, i, j;
    while(~scanf("%d%d",&n,&m))
    {
        int sum = 0;
        memset(dp,0,sizeof(dp));
        for(i = 1; i <= n; i++)
        {
            scanf("%d",&h[i]);
            sum += h[i];
        }
        for(i = 1; i <= n; i++)
            for(j = sum; j >= h[i]; j--)
                dp[j] = max(dp[j], dp[j - h[i]] + h[i]);
        int Min = sum;
        for(i = m; i <= sum; i++)
            if(dp[i] >= m && dp[i] - m < Min)
                Min = dp[i] - m;
        printf("%d\n",Min);
    }
    return 0;
}

C++版本三

DFS 

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int h[22], ans, flag;
int n, m;
void dfs(int k, int s)
{
	if(s == m)
	{
		ans = 0;
		return ;
	}
	if(s >= m)
	{
		if(s - m < ans)
			ans = s - m;
		return ;
	}
	for(int i = k; i < n; i++)
	{
		dfs(i+1,s+h[i]);
	}
}
int main()
{
	int i;
	while(cin >> n >> m)
	{
		int sum = 0;
		flag = 0;
		for(i = 0; i < n; i++)
		{
			cin >> h[i];
			sum += h[i];
		}
		if(sum == m)
		{
			cout << "0" << endl;
			continue;
		}
		ans = sum;
		dfs(0,0);
		cout << ans << endl;
	}
	return 0;
}

 

全部评论

相关推荐

与火:这不接? 留子的钱不挣白不挣
点赞 评论 收藏
分享
11-06 10:58
已编辑
门头沟学院 嵌入式工程师
双非25想找富婆不想打工:哦,这该死的伦敦腔,我敢打赌,你简直是个天才,如果我有offer的话,我一定用offer狠狠的打在你的脸上
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务