Currency Exchange

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

C++版本一

SPFA

#include<stdio.h>
#include<string.h>

double c[110],d[110],e[110],f[110],v,dis[110];
int a[110],b[110],n,m,s;

int main()
{
	int i,k,flag;

	while(~ scanf("%d %d %d %lf",&n,&m,&s,&v))
	{
		memset(dis,0,sizeof(dis));
		for(i = 1;i<=m;i ++)
		{
			scanf("%d %d %lf %lf %lf %lf",&a[i],&b[i],&c[i],&d[i],&e[i],&f[i]);
		}
		dis[s] = v;
		int find;
		for(k = 1;k<=n-1;k ++)
		{
			find = 0;
			for(i = 1;i<=m;i ++)
			{
				if(dis[a[i]]<(dis[b[i]]-f[i])*e[i])
				{
					dis[a[i]] = (dis[b[i]]-f[i])*e[i];
					find = 1;
				}
				if(dis[b[i]] < (dis[a[i]]-d[i])*c[i])
				{
					dis[b[i]] = (dis[a[i]]-d[i])*c[i];
					find = 1;
				}
			}
			if(find == 0)
			break;
		}
		flag = 0;
		for(i = 1;i<=n;i ++)
		{
			if(dis[a[i]] < (dis[b[i]]-f[i])*e[i])
			{
				flag = 1;
				break;
			}
			if(dis[b[i]] < (dis[a[i]]-d[i])*c[i])
			{
				flag = 1;
				break;
			}
		}
		if(flag == 1)
		printf("YES\n");
		else
		printf("NO\n");
	}
	return 0;
}

C++版本二

Bellman_Ford

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#define INF 0x3f3f3f3f
#define mod 1000000007
 
using namespace std;
 
int s,n,m,k;
double v;
struct node
{
    int a,b;
    double r,c;
}arr[202];
double dis[200];
int bf()
{
    int i,j;
    memset(dis,0,sizeof(dis));
    dis[s]=v;
    for (i=1;i<n;i++)
    {
        int flag=0;
        for (j=0;j<k;j++)
        {
            int a=arr[j].a,b=arr[j].b;
            if(dis[b]<(dis[a]-arr[j].c)*arr[j].r)
                {dis[b]=(dis[a]-arr[j].c)*arr[j].r;flag=1;}
        }
        if(!flag) break;
    }
    for (i=0;i<k;i++)
        if(dis[arr[i].b]<(dis[arr[i].a]-arr[i].c)*arr[i].r)
        return 1;
    return 0;
}
 
int main()
{
    int a,b,i;
    double rab,cab,rba,cba;
    while (~scanf("%d%d%d%lf",&n,&m,&s,&v))
    {
        k=0;
        for (i=1;i<=m;i++)
        {
            scanf("%d%d%lf%lf%lf%lf",&a,&b,&rab,&cab,&rba,&cba);
            arr[k].a=a;
            arr[k].b=b;
            arr[k].r=rab;
            arr[k++].c=cab;
            arr[k].a=b;
            arr[k].b=a;
            arr[k].r=rba;
            arr[k++].c=cba;
        }
        if(bf())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

全部评论

相关推荐

不愿透露姓名的神秘牛友
11-27 10:28
点赞 评论 收藏
分享
挣K存W养DOG:他真的很中意你,为什么不回他
点赞 评论 收藏
分享
Yushuu:你的确很厉害,但是有一个小问题:谁问你了?我的意思是,谁在意?我告诉你,根本没人问你,在我们之中0人问了你,我把所有问你的人都请来 party 了,到场人数是0个人,誰问你了?WHO ASKED?谁问汝矣?誰があなたに聞きましたか?누가 물어봤어?我爬上了珠穆朗玛峰也没找到谁问你了,我刚刚潜入了世界上最大的射电望远镜也没开到那个问你的人的盒,在找到谁问你之前我连癌症的解药都发明了出来,我开了最大距离渲染也没找到谁问你了我活在这个被辐射蹂躏了多年的破碎世界的坟墓里目睹全球核战争把人类文明毁灭也没见到谁问你了😆
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务