More is better

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2


        
  

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 C++版本一

 

#include <iostream>
#include <stdio.h>
#include <algorithm>

using namespace std;
const int N=10000000+10;
int n,pre[N],ranksize[N];
int find(int x){
    int r=x;
    while(pre[r]!=r)
        r=pre[r];
    return r;
}
void join(int x,int y){
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy){
        if(ranksize[fx]>=ranksize[fy]){
            pre[fy]=fx;
            ranksize[fx]+=ranksize[fy];
        }else{
            pre[fx]=fy;
            ranksize[fy]+=ranksize[fx];
        }
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF){
        if(n==0){
            cout << 1 << endl;
            continue;
        }
        for(int i=1;i<N;i++){
            pre[i]=i;
            ranksize[i]=1;
        }
        int a,b;
        int m=0;
        for(int i=1;i<=n;i++){
            scanf("%d%d",&a,&b);
            m=max(m,max(a,b));
            join(a,b);
        }
        int maxn=1;
        for(int i=1;i<=m;i++){

            maxn=max(maxn,ranksize[i]);
        }
        cout << maxn << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}

C++版本二

只需用一个rank记录每个节点下面有多少个人,并在合并的时候累加给上一级

需要注意当n==0时,输出为1

#include <stdio.h>
 
struct Node{
    int pre;
    int rank;
}tree[10000005];
int maxn;
 
int Find(int x){
    int p = x;
    while(tree[p].pre != p){
        p = tree[p].pre;
    }
    int i = x;
    while(i != p){
        int j = tree[i].pre;
        tree[i].pre = p;
        i = j;
    }
    return p;
}
 
void Join(int x,int y){
    int fx = Find(x);
    int fy = Find(y);
    if(fx != fy){
        tree[fy].rank += tree[fx].rank;
        if(tree[fy].rank > maxn){
            maxn = tree[fy].rank;
        }
        tree[fx].pre = fy;
    }
}
 
int main(){
    int n;
    int i,j;
    int x,y;
 
    while(scanf("%d",&n) != EOF){
        maxn = 1;
        for(i = 0;i < 10000005;i++){
            tree[i].pre = i;
            tree[i].rank = 1;
        }
        for(i = 0;i < n;i++){
            scanf("%d%d",&x,&y);
            Join(x,y);
        }
        printf("%d\n",maxn);
    }
    return 0;
}

 

全部评论

相关推荐

10-25 12:05
已编辑
湖南科技大学 Java
若梦难了:我有你这简历,已经大厂乱杀了
点赞 评论 收藏
分享
评论
点赞
收藏
分享
正在热议
# 25届秋招总结 #
440577次浏览 4493人参与
# 春招别灰心,我们一人来一句鼓励 #
41484次浏览 524人参与
# 阿里云管培生offer #
119857次浏览 2219人参与
# 地方国企笔面经互助 #
7928次浏览 18人参与
# 同bg的你秋招战况如何? #
75577次浏览 552人参与
# 虾皮求职进展汇总 #
114215次浏览 884人参与
# 北方华创开奖 #
107309次浏览 599人参与
# 实习,投递多份简历没人回复怎么办 #
2454001次浏览 34848人参与
# 实习必须要去大厂吗? #
55678次浏览 960人参与
# 提前批简历挂麻了怎么办 #
149825次浏览 1977人参与
# 投递实习岗位前的准备 #
1195707次浏览 18546人参与
# 你投递的公司有几家约面了? #
33180次浏览 188人参与
# 双非本科求职如何逆袭 #
661910次浏览 7394人参与
# 如果公司给你放一天假,你会怎么度过? #
4730次浏览 55人参与
# 机械人春招想让哪家公司来捞你? #
157604次浏览 2267人参与
# 如果你有一天可以担任公司的CEO,你会做哪三件事? #
11365次浏览 270人参与
# 发工资后,你做的第一件事是什么 #
12418次浏览 61人参与
# 工作中,努力重要还是选择重要? #
35612次浏览 384人参与
# 参加完秋招的机械人,还参加春招吗? #
20091次浏览 240人参与
# 我的上岸简历长这样 #
451924次浏览 8088人参与
# 实习想申请秋招offer,能不能argue薪资 #
39235次浏览 314人参与
# 非技术岗是怎么找实习的 #
155850次浏览 2120人参与
牛客网
牛客企业服务