hdu5528Count a * b(数论)

题目链接https://cn.vjudge.net/problem/HDU-5528

Marry likes to count the number of ways to choose two non-negative integers a and b less than m to make a×b mod m≠0. 

Let's denote f(m)as the number of ways to choose two non-negative integers a and b less than m to make a×b mod m≠0. 

She has calculated a lot of f(m) for different mm, and now she is interested in another function g(n)=∑m|nf(m). For example, g(6)=f(1)+f(2)+f(3)+f(6)=0+1+4+21=26. She needs you to double check the answer. 



Give you nn. Your task is to find g(n) modulo 2^64.

Input

The first line contains an integer T indicating the total number of test cases. Each test case is a line with a positive integer nn. 

1≤T≤20000
1≤n≤10^9

Output

For each test case, print one integer ss, representing g(n) modulo 2^64.

Sample Input

2
6
514

Sample Output

26
328194

听说结果没有大于等于2^64的,直接用long long算???

推导见大神博客https://blog.csdn.net/Coldfresh/article/details/82189233

 

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<map>
#include<vector>
#include<set>
#include<list>
#include<stack>
#include<queue>
using namespace std;
typedef long long ll;
const int N=4e4+5;
bool p[N];
int prime[N],cnt=0; 
void init(){
	p[0]=p[1]=true;
	for(int i=2;i<N;i++){
		if(!p[i]) prime[cnt++]=i;
		for(int j=0;j<cnt&&(ll)i*prime[j]<N;j++){
			p[i*prime[j]]=true;
			if(i%prime[j]==0) break;
		}
	}
}
int fac[50],e[50];
ll k,ans;
void getFac(int x){        //唯一分解 
	k=0;
	for(int i=0;i<cnt&&x!=1;i++){
		if(x%prime[i]==0){
			fac[k]=prime[i];
			e[k]=0;
			while(x%prime[i]==0){
				x/=prime[i];
				e[k]++;
			}
			k++;
		}
	}
	if(x!=1){
		fac[k]=x;
		e[k]=1;
		k++;
	}
}
void dfs(int pos,ll temp){ //dfs枚举因子 
	if(pos==k){
		ans+=temp*temp;
		return ;
	}
	dfs(pos+1,temp);
	ll t=temp;
	for(int i=1;i<=e[pos];i++){
		t*=fac[pos];
		dfs(pos+1,t);
	}
}
ll solve(int x){
   getFac(x);
   ll a=1;
   for(int i=0;i<k;i++){
   	   a*=e[i]+1;
   }
   ans=0-a*x;
   dfs(0,1);
   return ans;
}
int main(){
    init();
    int T;
    scanf("%d",&T);
    while(T--){
    	int x;
    	scanf("%d",&x);
    	printf("%lld\n",solve(x));
	}
	return 0;
}



 

全部评论

相关推荐

02-22 18:38
门头沟学院 Java
程序员牛肉:标准的NPC简历,一个短链接+12306。你可以在牛客上面搜一搜有多少人的简历和你一样。你自己能不能给出你一个理由让面试官在大家简历高度相同的情况下,选择约面你而不是对应的211,985学生? 是因为你即将拥有的那段小厂实习吗?这种小厂实习真的很有含金量吗?因此你可以找实习,但是你如果只能找到小厂实习的话,其实意义不太大。 但你的时间是充足的,相信我:从现在到今年的九月份大三上你就干两个事情:"写博客"+“参加开源之夏”。这两个搞好了不亚于一段大厂实习的含金量。 想要让自己变得更强,首先就是不要把自己当打工人看待,让自己简历上面的活人气息更多一点,不要让自己成为流水线的产物。你不是在出售你的技能,你是在利用你的技能和公司达成一种合作关系。
点赞 评论 收藏
分享
02-22 20:28
重庆大学 Java
程序员牛肉:首先不要焦虑,你肯定是有希望的。 首先我觉得你得好好想一想自己想要什么。找不到开发岗就一定是失败的吗?那开发岗的35岁危机怎么说?因此无论是找工作还是考公我觉得你都需要慎重的想一想。但你一定要避开这样一个误区:“我是因为找不到工作所以不得不选择考公”。 千万不要这么想。你这个学历挺好的了,因此你投后端岗肯定是有面试机会的。有多少人简历写的再牛逼,直接连机筛简历都过不去有啥用?因此你先保持自信一点。 以你现在的水平的话,其实如果想要找到暑期实习就两个月:一个月做项目+深挖,并且不断的背八股。只要自己辛苦一点,五月份之前肯定是可以找到暑期实习的,你有点太过于高看大家之间的技术差距了。不要焦虑不要焦虑。 除此之外说回你这个简历内容的话,基本可以全丢了。如果想做后端,先踏踏实实做两个项目再说+背八股再说。如果想考公,那就直接备战考公。 但是但是就像我前面说的:你考公的理由可以是因为想追求稳定,想追求轻松。但唯独不能是因为觉得自己找不到工作。不能这么小瞧自己和自己的学历。
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务