hdu3833YY's new problem

这个题又是想难了,联想到poj2549 看了题解 自己写WA了好多次 ==其实之前犯过这个错误T^T 跳出循环时要注意 题中给的数得读入结束才行 长点心吧。。。

Problem Description
Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i 1], P[i 2], P[i 3] that
P[i 1]-P[i 2]=P[i 2]-P[i 3], 1<=i 1<i 2<i 3<=N.
 

Input
The first line is T(T<=60), representing the total test cases.
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
 

Output
For each test case, just output 'Y' if such i 1, i 2, i 3 can be found, else 'N'.
 

Sample Input
2 3 1 3 2 4 3 2 4 1
 

Sample Output
N Y
 
#include <iostream>
#include<cstdio>
#include<cstring>
//#include<algorithm>
#define mm 10003
using namespace std;
int t,n,s,flag;
int hsh[mm];
int main()
{
   // freopen("cin.txt","r",stdin);
    cin>>t;
    while(t--)
    {
         cin>>n;
         memset(hsh,0,sizeof(hsh));
         flag=0;
         for(int i=0;i<n;i++)
         {
              scanf("%d",&s);
              hsh[s]=1;
              if(flag==0)
              {
              for(int j=1;j<s&&j+s<=n;j++)
              {
                   if(hsh[s+j]+hsh[s-j]==1)
                   {
                        flag=1;
                        break;
                   }
              }                   
              }

              //if(flag) break;//就是这里 如果这么就跳出来了 会有数没读完
         }
         if(flag) cout<<"Y"<<endl;
         else cout<<"N"<<endl;
    }
    return 0;
}


全部评论

相关推荐

勇敢大角牛2:项目太基础了。小demo就不要往简历中写了,得分是什么鬼,大作业?。并且项目经历和你的求职意向岗位不匹配,没有体现硬件的亮点。话有点糙,还请谅解
点赞 评论 收藏
分享
一个菜鸡罢了:哥们,感觉你的简历还是有点问题的,我提几点建议,看看能不能提供一点帮助 1. ”新余学院“别加粗,课程不清楚是否有必要写,感觉版面不如拿来写一下做过的事情,教育经历是你的弱势就尽量少写 2. “干部及社团经历”和“自我评价”删掉 3. 论文后面的“录用”和“小修”啥的都删掉,默认全录用,问了再说,反正小修毕业前肯定能发出来 4. 工作经验和研究成果没有体现你的个人贡献,着重包装一下个人贡献
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务