HDU - 3790 (双标准限制最短路径)最短路径问题

         最短路径问题 HDU 3790
 

给你n个点,m条无向边,每条边都有长度d和花费p,给你起点s终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。
Input输入n,m,点的编号是1~n,然后是m行,每行4个数 a,b,d,p,表示a和b之间有一条边,且其长度为d,花费为p。最后一行是两个数 s,t;起点s,终点。n和m为0时输入结束。 
(1<n<=1000, 0<m<100000, s != t)Output输出 一行有两个数, 最短距离及其花费。Sample Input
3 2
1 2 5 6
2 3 4 5
1 3
0 0
Sample Output
9 11
          这是一道加了限制的最短路径题~~其实就是在普通的最短路径的搜寻中多加了几个关于cost消费的判断而已~~以路径最短的优先~~相同的话就以消费最少优先。
#include<cstdio>
#include<queue>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int m,n;
struct ***
{
	int to;
	int len;
	int cos;
	int ne;
}ed[100005];
int head[1005];
int cnt = 0;
int vis[1005];
int d[1005];
int cost[1005];
void add(int from, int to, int len, int cos)
{
	ed[cnt].to = to;
	ed[cnt].len = len;
	ed[cnt].cos = cos;
	ed[cnt].ne = head[from];
	head[from] = cnt++;
}
void spfa(int x)
{
	vis[x] = 1;
	queue<int>q;
	q.push(x);
	d[x] = 0;
	cost[x] = 0;
	while (!q.empty())
	{
		int t = q.front();
		q.pop();
		for (int s = head[t]; ~s; s = ed[s].ne)
		{
			if (d[ed[s].to] > d[t] + ed[s].len)
			{
				d[ed[s].to] = d[t] + ed[s].len;
				cost[ed[s].to] = cost[t] + ed[s].cos;
				if (!vis[ed[s].to])
				{
					vis[ed[s].to] = 1;
					q.push(ed[s].to);
				}
			}
			else if (d[ed[s].to] == d[t] + ed[s].len)
			{
				cost[ed[s].to] = min(cost[ed[s].to], cost[t] + ed[s].cos);
			}
		}
		vis[t] = 0;
	}
}
void init()
{
	memset(head, -1, sizeof(head));
	for (int s = 1; s <= n; s++)
	{
		cost[s] = inf;
	}
	for (int s = 1; s <= n; s++)
	{
		d[s] = inf;
	}
	memset(vis, 0, sizeof(vis));
	cnt = 0;
	for (int s = 1; s <= n; s++)
	{
		head[s] = -1;
	}
}
int main()
{
	while (cin >> n >> m&&n+m)
	{
		init();
		while (m--)
		{
			int a, b, c, d;
			scanf("%d%d%d%d", &a, &b, &c, &d);
			add(a, b, c, d);
			add(b, a, c, d);
		}
		int a, b;
		cin >> a >> b;
	//	cout << d[b] << " " << cost[b] << endl;
		spfa(a);
		cout << d[b] << " " << cost[b] << endl;
	}
	return 0;
}




全部评论

相关推荐

10-15 10:57
已编辑
武昌理工学院 FPGA工程师
狠赚笔第一人:老哥学院本没实习还想拿13k学Java狠赚笔呢
点赞 评论 收藏
分享
totoroyyw:千年老妖😂
投递华为等公司10个岗位
点赞 评论 收藏
分享
秋招进行到现在终于能写总结了。完全没想到战线会拉这么长,过程会如此狼狈,不过更应该怪自己太菜了。好在所有的运气都用在了最后,也是有个去处。背景:双2本硕科班,无竞赛,本科一段研究所实习,硕士一段大厂暑期实习但无转正。技术栈是C++&nbsp;&amp;&nbsp;Golang,实习是客户端音视频(而且是鸿蒙端开发),简历两个C++项目一个Golang项目。主要投递岗位:后端,cpp软开,游戏服务端,测开,以及一些不拘泥于Java的岗位。从8月起总共投递123家公司,笔试数不清了,约面大约30家。offer/oc/意向:友塔游戏(第一个offer,面试体验很好,就是给钱好少南瑞继保(计算机科班点击就送(限男生),不...
乡土丁真真:佬很厉害,羡慕~虽然我还没有到校招的时候,也想讲一下自己的看法:我觉得不是CPP的问题,佬的背书双2,技术栈加了GO,有两段实习。投了123,面了30.拿到11个offer。这个数据已经很耀眼了。这不也是CPP带来的吗?当然也不止是CPP。至少来说在这个方向努力过的也会有好的结果和选择。同等学历和项目选java就会有更好的吗?我个人持疑问态度。当然CPP在方向选择上确实让人头大,但是我觉得能上岸,至于最后做什么方向,在我看来并不重要。至于CPP特殊,有岗位方向的随机性,java不是不挑方向,只是没得选而已。也希望自己以后校招的时候能offer满满
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务