POJ__3723 Conscription 最小生成树~
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 15918 | Accepted: 5508 |
Description
Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.
Input
The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.
1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000
Output
Sample Input
2 5 5 8 4 3 6831 1 3 4583 0 0 6592 0 1 3063 3 3 4975 1 3 2049 4 2 2104 2 2 781 5 5 10 2 4 9820 3 2 6236 3 1 8864 2 4 8326 2 0 5156 2 0 1463 4 1 2439 0 4 4373 3 4 8889 2 4 3133
Sample Output
71071 54223
Source
POJ Monthly Contest – 2009.04.05, windy7926778
给你选n+m个人进队~~他们之间有r条关系~每个关系只能用一次~每次会减少d点花费~每个人本来要1W~请问最少要花费多少~用最小生成数来查找最小的结果就好了
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<queue>
using namespace std;
int fa[50000];
struct ***
{
int boy,gril,rala;
}ral[200000];
int cnt;
void add(int a,int b,int c)
{
ral[cnt].boy=a;
ral[cnt].gril=b;
ral[cnt++].rala=-c;
}
int fin(int x)
{
if(x!=fa[x])
{
fa[x]=fin(fa[x]);
}
return fa[x];
}
int uni(int a,int b)
{
a=fin(a);
b=fin(b);
if(a!=b)
{
fa[a]=b;
return 1;
}
return 0;
}
bool cmp(*** a,*** b)
{
return a.rala<b.rala;
}
int main()
{
int te;
scanf("%d",&te);
while(te--)
{
cnt=0;
int n,m,r;
cin>>n>>m>>r;
for(int s=0;s<r;s++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
add(a,b+n,c);
}
for(int s=0;s<=n+m;s++)
{
fa[s]=s;
}
sort(ral,ral+cnt,cmp);
long long int ans=(n+m)*10000;
for(int s=0;s<cnt;s++)
{
int a=uni(ral[s].boy,ral[s].gril);
ans+=a*ral[s].rala;
}
cout<<ans<<endl;
}
return 0;
}