HDU - 1698 Just a Hook(线段树区间更新区间查找)

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 41024    Accepted Submission(s): 19780


 

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
 



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

 

 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

 

 

Sample Input


 

1 10 2 1 5 2 5 9 3

 

 

Sample Output


 

Case 1: The total value of the hook is 24.

 

 

Source

2008 “Sunline Cup” National Invitational Contest

 

 

Recommend

wangye

 

 

          线段树的区间查找区间修改,需要运用到懒惰数组~~模板题,记录一下

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int n, m;
int c[800005];
int lazy[800005];
void pushup(int x)
{
	c[x] = c[x << 1] + c[x << 1 | 1];
}
void pushdown(int rt,int m)
{
	if (lazy[rt])
	{
		lazy[rt << 1] = lazy[rt << 1 | 1] = lazy[rt];
		c[rt << 1] = (m - (m >> 1))*lazy[rt];
		c[rt << 1 | 1] = (m >> 1)*lazy[rt];
		lazy[rt] = 0;
	}
}
void build(int l, int r, int rt)
{
	lazy[rt] = 0;
	c[rt] = l - r + 1;
	if (l == r)
	{
		return;
	}
	int m = (l + r) >> 1;
	build(l, m, rt << 1);
	build(m + 1, r, rt << 1 | 1);
}
void see(int l, int r, int rt)
{
	cout << l << " " << r << " " << c[rt] << endl;
	if (l == r)
	{
		return;
	}
	cout << "sads" << endl;
	int m = (l + r) >> 1;
	see(l, m, rt << 1);
	see(m + 1, r, rt << 1 | 1);
}
void updata(int L, int R,int d, int l, int r, int rt)
{
	if (L <= l&&r <= R)
	{
		c[rt] = d*(r - l + 1);
		lazy[rt] = d;
		return;
	}
	pushdown(rt, r - l + 1);
	int m = (l + r) >> 1;
	if (L <= m)
	{
		updata(L, R, d, l, m, rt << 1);
	}
	if (R > m)
	{
		updata(L, R, d, m + 1, r, rt << 1 | 1);
	}
	pushup(rt);
}
int query(int L, int R, int l, int r, int rt)
{
	if (L <= l&&r <= R)
	{
		return c[rt];
	}
	int m = (l + r) >> 1;
	int ans = 0;
	if (L <= m)
	{
		ans = max(query(L, R, l, m, rt << 1), ans);
	}
	if (R > m)
	{
		ans = max(query(L, R, m + 1, r, rt << 1 | 1), ans);
	}
	return ans;
}
int main()
{
	int te, cas = 1;
	scanf("%d", &te);
	while (te--)
	{
		scanf("%d", &n);
		build(1, n, 1);
		scanf("%d", &m);
		while (m--)
		{
			int a, b, d;
			scanf("%d%d%d", &a, &b, &d);
			updata(a, b, d, 1, n, 1);
		//	see(1, n, 1);
		}
		printf("Case %d: The total value of the hook is %d.\n", cas++, c[1]);
	}
}

 

全部评论

相关推荐

已老实求offer😫:有点像徐坤(没有冒犯的意思哈)
点赞 评论 收藏
分享
10-28 14:42
门头沟学院 Java
watermelon1124:因为嵌入式炸了
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务