HDU - 2444 The Accomodation of Students (判断二分图+匈牙利算法)

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8705    Accepted Submission(s): 3830


 

Problem Description

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

 

 

Input

For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.
 

 

 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

 

 

Sample Input


 

4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6

 

 

Sample Output


 

No 3

 

 

Source

2008 Asia Harbin Regional Contest Online

 

 

Recommend

gaojie

 

     就是让你先进行判断是否形成二分图,不能的话输出No,能的话输出最大匹配值;

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
vector<int>ed[500];
int coler[500];
int vis[500];
int use[500];
bool dfs(int x, int col) 
{
	//cout << x << " " << col << endl;
	coler[x] = col;
	for (int s = 0; s < ed[x].size(); s++) {	
		if (coler[ed[x][s]] == col)return 0;
		if (coler[ed[x][s]] == 0 && !dfs(ed[x][s], 3 - col))return 0;
	}
	return 1;
}
int find(int x)
{
	for (int s = 0; s < ed[x].size(); s++) {
		if (!vis[ed[x][s]]) {
			vis[ed[x][s]] = 1;
			if (use[ed[x][s]] == 0 || find(use[ed[x][s]]))
			{
				use[ed[x][s]] = x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int n, m;
	while (~scanf("%d%d", &n, &m))
	{
		memset(use, 0, sizeof(use));
		memset(vis, 0, sizeof(vis));
		memset(coler, 0, sizeof(coler));
		for (int s = 1; s <= n; s++) {
			ed[s].clear();
		}
		for (int s = 0; s < m; s++) {
			int a, b;
			scanf("%d%d", &a, &b);
			ed[a].push_back(b);
			ed[b].push_back(a);
		}
		int spot = 0;
		for (int s = 1; s <= n; s++) {
			if(coler[s]==0)
				if (!dfs(s, 1)) {
					cout << "No" << endl;
					spot = 1;
					break;
				}
		}
		if (spot) continue;
		int sum = 0;
		for (int s = 1; s <= n; s++) {
			memset(vis,0,sizeof(vis));
			if (coler[s] == 1 && find(s)) {
				sum++;
			}
		}
		cout << sum << endl;
	}
}

 

全部评论

相关推荐

11-26 22:34
已编辑
重庆邮电大学 Java
快手 客户端开发 (n+5)k*16 公积金12
牛客895077908号:佬 什么双非硕啊
点赞 评论 收藏
分享
我在朝九晚六双休的联想等你:如果我是你,身体素质好我会去参军,然后走士兵计划考研211只需要200多分。
点赞 评论 收藏
分享
11-02 09:49
已编辑
货拉拉_测试(实习员工)
热爱生活的仰泳鲈鱼求你们别卷了:没事楼主,有反转查看图片
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务