HDU - 4417 Super Mario (划分树+二分)

Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.

Input

The first line follows an integer T, the number of test data. 
For each test data: 
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries. 
Next line contains n integers, the height of each brick, the range is [0, 1000000000]. 
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)

Output

For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query. 

Sample Input

1
10 10
0 5 2 7 5 4 3 8 7 7 
2 8 6
3 5 0
1 3 1
1 9 4
0 1 0
3 5 5
5 5 1
4 6 3
1 5 7
5 7 3

Sample Output

Case 1:
4
0
0
3
1
2
0
1
5
1

          

      静态查找某个区间内所指示的数k比几个数大。。。建划分树直接暴力二分查找看看是第几大。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 200010;
int tree[20][maxn];
int sorted[maxn];
int toleft[20][maxn];
void build(int l, int r, int dep) {
	if (l == r)return;
	int mid = (l + r) >> 1;
	int same = mid - l + 1;
	for (int i = l; i <= r; i++) {
		if (tree[dep][i] < sorted[mid])
			same--;
	}
	int lpos = l;
	int rpos = mid + 1;
	for (int i = l; i <= r; i++) {
		if (tree[dep][i] < sorted[mid])
			tree[dep + 1][lpos++] = tree[dep][i];
		else if (tree[dep][i] == sorted[mid] && same > 0) {
			tree[dep + 1][lpos++] = tree[dep][i];
			same--;
		}
		else
			tree[dep + 1][rpos++] = tree[dep][i];
		toleft[dep][i] = toleft[dep][l - 1] + lpos - l;
	}
	build(l, mid, dep + 1);
	build(mid + 1, r, dep + 1);
}
int query(int L, int R, int l, int r, int dep, int k) {
	if (l == r)return tree[dep][l];
	int mid = (L + R) >> 1;
	int cnt = toleft[dep][r] - toleft[dep][l - 1];
	if (cnt >= k) {
		int newl = L + toleft[dep][l - 1] - toleft[dep][L - 1];
		int newr = newl + cnt - 1;
		return query(L, mid, newl, newr, dep + 1, k);
	}
	else {
		int newr = r + toleft[dep][R] - toleft[dep][r];
		int newl = newr - (r - l - cnt);
		return query(mid + 1, R, newl, newr, dep + 1, k - cnt);
	}
}
int main() {
	int n, m;
	int te, cas = 1;
	scanf("%d", &te);
	while (te--) {
		scanf("%d%d", &n, &m);
		printf("Case %d:\n", cas++);
		for (int i = 1; i <= n; i++) {
			scanf("%d", &tree[0][i]);
			sorted[i] = tree[0][i];
		}
		sort(sorted + 1, sorted + n + 1);
		build(1, n, 0);
		int s, t, k;
		while (m--) {
			scanf("%d%d%d", &s, &t, &k);
			s++; t++;
			int l = 1, r = (t - s + 1), ans = 0;
			while (l <= r) {
				int mid = (l + r) >> 1;
				int tmp = query(1, n, s, t, 0, mid);
			//	cout << l << " " << r << " tmp: " << tmp << " k:" << k << endl;
				if (tmp<= k) {
					ans = mid;
					l = mid + 1;
				}
				else {
					r = mid - 1;
				}
			}
			printf("%d\n", ans);
		}
	}
	return 0;
}

 

全部评论

相关推荐

威猛的小饼干正在背八股:挂到根本不想整理
点赞 评论 收藏
分享
ArisRobert:统一解释一下,第4点的意思是,公司按需通知员工,没被通知到的员工是没法去上班的,所以只要没被通知到,就自动离职。就是一种比较抽象的裁员。
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务