每日一九度之 题目1039:Zero-complexity Transposition

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3372

解决:1392

<dl> <dt> 题目描述: </dt> <dd>

You are given a sequence of integer numbers. Zero-complexity transposition of the sequence is the reverse of this sequence. Your task is to write a program that prints zero-complexity transposition of the given sequence.

</dd> </dl> <dl> <dt> 输入: </dt> <dd>

For each case, the first line of the input file contains one integer n-length of the sequence (0 < n ≤ 10 000). The second line contains n integers numbers-a1, a2, …, an (-1 000 000 000 000 000 ≤ ai ≤ 1 000 000 000 000 000).

</dd> </dl> <dl> <dt> 输出: </dt> <dd>

For each case, on the first line of the output file print the sequence in the reverse order.

</dd> </dl> <dl> <dt> 样例输入: </dt> <dd>
5
-3 4 6 -8 9
</dd> </dl> <dl> <dt> 样例输出: </dt> <dd>
9 -8 6 4 -3
</dd> </dl>

水题,但是因为是英文,出了一点小(不)问(认)题(识)。

本来认为是绝对值排序,但是后来仔细一看,原来就只是把数组反过来输出就好了。

看懂题目很重要。。是的,真的很重要!

这是不改变数组,直接反过来输出的。

//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <map>
#include <string>
#include <queue>
#define INF 100000
using namespace std;
const int maxn = 10005;
typedef long long ll;
int n, m;
ll a[maxn];

int main(){
    while( ~scanf("%d", &n) ){
        for(int i=0; i<n; i++){
            scanf("%ld",&a[i]);
        } 
        for(int i=n-1; i>=0; i--){ 
            printf(i==0?"%ld\n":"%ld ",a[i]);
        }
    }
    return 0;
}


做了一点小处理,将数组反了过来。

//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <map>
#include <string>
#include <queue>
#define INF 100000
using namespace std;
const int maxn = 10005;
typedef long long ll;
int n, m;
ll a[maxn];

int main(){
    while( ~scanf("%d", &n) ){
        for(int i=0; i<n; i++){
            scanf("%ld",&a[i]);
        }
        for(int i=0; i<n/2; i++){
            ll temp = a[i];
            a[i] = a[n-1-i];
            a[n-1-i] = temp;
        }
        for(int i=0; i<n; i++){
            printf(i==n-1?"%ld\n":"%ld ",a[i]);
        }
    }
    return 0;
}

 

全部评论

相关推荐

牛客鼠:校友你这简历基本无敌了,春招刷刷题去冲大厂
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务