每日一九度之 题目1042:Coincidence

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:3007

解决:1638

<dl> <dt> 题目描述: </dt> <dd>

Find a longest common subsequence of two strings.

</dd> </dl> <dl> <dt> 输入: </dt> <dd>

First and second line of each input case contain two strings of lowercase character a…z. There are no spaces before, inside or after the strings. Lengths of strings do not exceed 100.

</dd> </dl> <dl> <dt> 输出: </dt> <dd>

For each case, output k – the length of a longest common subsequence in one line.

</dd> </dl> <dl> <dt> 样例输入: </dt> <dd>
abcd
cxbydz
</dd> </dl> <dl> <dt> 样例输出: </dt> <dd>
2
</dd> </dl>

经典的dp问题。LCS。相当于dp的入门级题目吧!

//Asimple
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <stack>
#include <cmath>
#include <set>
#include <map>
#include <string>
#include <queue>
#include <limits.h>
#define INF 0x7fffffff
using namespace std;
const int maxn = 115;
typedef long long ll;
int n, num;
char s1[maxn], s2[maxn];
int dp[maxn][maxn];

int main(){
    while( cin >> s1 >> s2 ){
        int len1 = strlen(s1);
        int len2 = strlen(s2);
        for (int i=0; i<=len1; ++i)  
            dp[i][0] = 0;  
       for (int j=0; j<=len2; ++j)  
            dp[0][j] = 0; 
        for(int i=1; i<=len1; i++){
            for(int j=1; j<=len2; j++){
                if( s1[i-1] == s2[j-1] ){
                    dp[i][j] = dp[i-1][j-1] + 1;
                } else {
                    dp[i][j] = max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}

 

全部评论

相关推荐

点赞 评论 收藏
分享
北斗导航Compass低仿版:没必要写这么多东西,还是尽量浓缩成一页,自我评价,git和cursor Trae这些都可以去掉。实习经历的描述最好根据star法则改一下,别这么直白
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务