Doing Homework HDU - 1074

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

InputThe input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier. 
OutputFor each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one. 
Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the 
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

第一个DP状态压缩的题,看了好久。希望下次做的时候可以懂一点点吧。

// Asimple
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <vector>
#include <string>
#include <cstring>
#include <stack>
#define INF 0x3f3f3f3f
#define mod 2016
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = (1<<15)+10;
int n, m, T, len, cnt, num, ans, Max;
int dp[maxn], t[maxn], pre[maxn], d[20], f[20];
char str[20][105];

void output(int x) {
    if( !x ) return ;
    output(x-(1<<pre[x]));
    printf("%s\n", str[pre[x]]);
}

void input() {
    scanf("%d", &T);
    while( T -- ) {
        scanf("%d", &n);
        for(int i=0; i<n; i++) scanf("%s%d%d",str[i], &d[i], &f[i]);
        int bit = 1 << n;
        for(int i=1; i<=bit; i++) {
            dp[i] = INF;
            for(int j=n-1; j>=0; j--) {
                int te = 1<<j;
                if( !(i&te) ) continue;
                int sc = t[i-te]+f[j]-d[j];
                if( sc<0 ) sc = 0;
                if( dp[i]>dp[i-te]+sc) {
                    dp[i] = dp[i-te]+sc;
                    t[i] = t[i-te]+f[j];
                    pre[i] = j;
                }
            }
        }
        printf("%d\n", dp[bit-1]);
        output(bit-1);
    }
}

int main() {
    input();
    return 0;
} 

感谢大神http://blog.csdn.net/xingyeyongheng/article/details/21742341

全部评论

相关推荐

01-14 12:08
门头沟学院 Java
神哥了不得:(非引流)1.既然发出来了简历,就稍微提一点点小建议,确实简历很不错了,练手项目可以换一些质量高的,工作内容,可以加上一些量化指标,比如第一条系统响应速度由多少变成多少,减少了百分之多少,第4条就很不错。2.广投,年前实习招募比较少了
点赞 评论 收藏
分享
给🐭🐭个面试机会吧:我boss直聘天天有家教跟我打招呼😓
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务